External dependencies

Required dependences

eProsima Micro XRCE-DDS Client does not require external dependencies.

eProsima Micro XRCE-DDS Agent requires the following packages to work:

eProsima Fast RTPS
eProsima Fast RTPS could be installed following the instructions: eProsima Fast RTPS installation guide.

Windows

Microsoft Visual C++ 2015 or 2017
eProsima Micro XRCE-DDS is supported on Windows over Microsoft Visual C++ 2015 and 2017 framework.

Additional Dependencies

The following dependences are not necessary to run eProsima Micro XRCE-DDS.

GTEST
Gtest is the framework used to test the code through a complete set of tests.
Java & Gradle
Java & Gradle is required to compile the code generation tool eProsima Micro XRCE-DDS Gen.